Jump to content

Create Capsules from String Scalars


Recommended Posts

Hi. I have following structure of the string descriptors of the batches, each having one timestamp at the beginning of the batch. I'd like to create a capsule starting at this timestamp and stretching all the way until the next datapoint:

capsules.thumb.png.7fdd5650b00bab1a3009f924ac211f5e.png

I've tried some tricks described in A Guide to Working with Capsule Properties, but most of the time it creates short capsules (I do not see capsule icons above the chart). The timestamp for batch name and "Inactive" looks to be at the same timestamp so I've removed them using 

$signal.remove(isEqualTo("Inactive")).toCapsules()
Timestamp Value
Jan 22, 2022 11:23 AM
Inactive
Jan 22, 2022 11:23 AM
2022_Batch2
Feb 19, 2022 10:23 PM
Inactive
Feb 19, 2022 10:23 PM
2022_Batch2

Now I only have 

Timestamp Value
Jan 22, 2022 11:23 AM 2022_Batch2
Feb 19, 2022 10:23 PM 2022_Batch2

and I would like to have a capsule containing value 2022_Batch2 lasting from Jan-22 to Feb-19 10:23. 

Second Question (seeing all data in table form😞

I'm not 100% sure what is the structure of the underlaying data (whether I have single record or a few records very close to each other). Can I see all the datapoint in Seeq? Table view offers various aggregations, but I didn't find a way how to see all the data points. 

Link to comment
Share on other sites

  • Seeq Team

Hi vadeka,

Now that you've removed the "Inactive" data the issue is likely that either (1) your maximum interpolation is not long enough to interpolate between those points or (2) there is actual invalid data (not just saying "Inactive", but a data point that is not visible as it doesn't have a value. Check out this post under Question 4 for how to solve this: 

 

 

In terms of your second question, if you want to view the data points on the trend, then check out how to adjust the "Samples" in the Customize menu for the Details Pane, which allows you to turn on the individual data points: https://support.seeq.com/space/KB/149651519/Adjusting+Signal+Lanes%2C+Axes+%26+Formatting. If you want to view it in a Table, then using $signal.tocapsules() will give you a capsule per data point so that you can view that in a Condition Table (https://support.seeq.com/space/KB/1617592515#Condition-Tables). Note that there are two similar functions: tocapsules will provide a capsule per data point (even if the data points are identical) whereas tocondition will provide a sample per change in data point, meaning it will not show repeat capsules if the data points are equivalent in sequence.

  • Like 1
Link to comment
Share on other sites

3 hours ago, Joe Reckamp said:

Hi vadeka,

Now that you've removed the "Inactive" data the issue is likely that either (1) your maximum interpolation is not long enough to interpolate between those points or (2) there is actual invalid data (not just saying "Inactive", but a data point that is not visible as it doesn't have a value. Check out this post under Question 4 for how to solve this: 

 

 

In terms of your second question, if you want to view the data points on the trend, then check out how to adjust the "Samples" in the Customize menu for the Details Pane, which allows you to turn on the individual data points: https://support.seeq.com/space/KB/149651519/Adjusting+Signal+Lanes%2C+Axes+%26+Formatting. If you want to view it in a Table, then using $signal.tocapsules() will give you a capsule per data point so that you can view that in a Condition Table (https://support.seeq.com/space/KB/1617592515#Condition-Tables). Note that there are two similar functions: tocapsules will provide a capsule per data point (even if the data points are identical) whereas tocondition will provide a sample per change in data point, meaning it will not show repeat capsules if the data points are equivalent in sequence.

Perfect, I've added .setmaxinterpolation(365d) and it started to work. 

$signal.remove(isEqualTo("Inactive")).setmaxinterpolation(365d).toCapsules()

And thanks for sharing additional information, like the difference between toCapsules and toCondition. That is very helpful. 

capsules_2.thumb.png.4ae31a47857863b26033141f2bd0cd25.png

Link to comment
Share on other sites

21 hours ago, Joe Reckamp said:

Hi vadeka,

Now that you've removed the "Inactive" data the issue is likely that either (1) your maximum interpolation is not long enough to interpolate between those points or (2) there is actual invalid data (not just saying "Inactive", but a data point that is not visible as it doesn't have a value. Check out this post under Question 4 for how to solve this: 

 

 

In terms of your second question, if you want to view the data points on the trend, then check out how to adjust the "Samples" in the Customize menu for the Details Pane, which allows you to turn on the individual data points: https://support.seeq.com/space/KB/149651519/Adjusting+Signal+Lanes%2C+Axes+%26+Formatting. If you want to view it in a Table, then using $signal.tocapsules() will give you a capsule per data point so that you can view that in a Condition Table (https://support.seeq.com/space/KB/1617592515#Condition-Tables). Note that there are two similar functions: tocapsules will provide a capsule per data point (even if the data points are identical) whereas tocondition will provide a sample per change in data point, meaning it will not show repeat capsules if the data points are equivalent in sequence.

Regarding the second question, how to see all the data, I've realized that export to excel works perfect. I needed those data for debugging. If I ever need to display them, I'll explore the options you provided. Thanks. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...