Jump to content

Table aggregation "Count" is not matching the number of data points


Recommended Posts

I am pulling in a relatively noisy signal, and trying to get a feel for how many raw data points I am looking at (to compare with how many points I see after several transformations). However, the "Count" column on the "Tables and Charts" view is way off of the number of records I get if I export that signal through "Import/Export" to Excel.

For example, for a signal shows "Count" of 2,343, but when I export that signal to Excel, there are 14,580 timestamps with a value. Even if I remove duplicates (thinking it is a distinct count) there are 3,908 values.

Is there something I need to do on the Seeq side to get an accurate count of the data points?

Thanks,

David

Link to comment
Share on other sites

  • Seeq Team

Hi David,

The count should be accurate in the Tables and Charts view. Are you using the "ungridded original timestamps" option in the export to Excel? If not, it could be exporting gridded samples, which could result in interpolated values coming out in your Excel export that aren't actually raw data points in your signal.

  • Thanks 1
Link to comment
Share on other sites

  • Seeq Team

Hi david,

To add to joe's comment:

Besides excel export and looking at this in tables and charts, an easier way to do this would be to simply add the count as a statistic in your details pane. to do this, click on the table icon in your details, it should be right underneath the "customize" button. In the pop up, simply select "count" and the count of data points for each signal will be displayed in the details pane.

image.png

Hope that helps!

Thanks,

Sean 

  • Thanks 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...