Jump to content

Daily Capsules Don't Start at Midnight


John Cox
 Share

Recommended Posts

  • Seeq Team

I have created a daily condition in Seeq using the Periodic Condition tool. Why don't the capsules start at midnight?

For example, in the screenshot below the "Daily" capsules start at 11:00PM (see the Capsules pane) instead of midnight (12:00AM). This results when the user interface (UI) time zone does not match that of the Seeq Server. In this example the Seeq Server time zone is US/Eastern but the UI time zone is US/Central. To make the UI time zone match, the user can click on the UI time zone link (noted by the red box in the screenshot: trend display, x-axis, right of timestamp): 

timezone1.jpg

 

The user can then set the "Always use:" option to US/Eastern (in this example the Seeq Server is on US/Eastern) as shown here:

timezone2.JPG

 

The daily capsules now start at midnight:

timezone3.JPG

Link to comment
Share on other sites

  • Seeq Team

The worksheet timezone changes the display of the timestamps, but it doesn't change the actual timestamps of the capsules. By default, all the periodic conditions are generated according to the server timezone. This can be overridden in in the advanced section of the tool as shown below.

tzselct.png

Selecting the correct timezone is important because it affects edge cases like daylight savings. Selecting a timezone that honors DST will produce the 25 or 23h capsule on the proper adjustment day.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...