Jump to content

Seeq not reconnecting to SQL Server


Thorsten Vogt
 Share

Recommended Posts

Hi,

I configured Seeq to use data from a SQL Server database. However, after rebooting the machine hosting SQL Server or restarting SQL Server service the connection in Seeq is not reestablished. Error message:

Error getting data: The target datasource is disconnected or no longer exists

I have to restart Seeq service to get this resolved. Is this a known issue and is there a way to get around this?

Regards, 

Thorsten

Link to comment
Share on other sites

  • Seeq Team

Hi Thorsten,

Current releases assume the connection is closed after the SQL server connection is lost and do not automatically try to connect again. Instead of restarting the Seeq service, you could edit the SQL Connector configuration file to resume a connection after the SQL server is rebooted or SQL service restarted. 

This has been addressed in an upcoming release (0.47.00). After you upgrade to this release when available, Seeq will make repeated attempts to connect to SQL servers that are appearing as disconnected so that the connection will resume when they become available again.

Thanks,

Joanna

Link to comment
Share on other sites

  • Seeq Team

Hi Thorsten,

The connector configuration files are always being monitored for changes. Just adding a white space and saving the file will be seen as a change and initiate Seeq to reconnect.

You can reconnect without indexing if you want, or you could have it index depending on how the connector is configured. If the configuration file has "OnStartupAndConfigChange" set to true for this connection, any white space change will be noticed as a change and indexing will be triggered on save. Alternatively, you could have this parameter be false and set the date/time in "Next" to be some time in the past. Then when saved, the connector will realize it needs to index as the next scheduled date is in the past and will find and index the connection. If this parameter is false and the date/time is in the future, the connection will be attempted again on save with a white space change, but indexing will not occur until the next scheduled date.

Regards,

Joanna

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...