Jump to content

OData Feed does not dynamically update on PowerBI [Fixed]


Recommended Posts

I have recently been completing my analysis on Seeq and exporting the final analysis to a visualization tool such as PowerBI.

Recently, I had to change the formula for a number of signals and capsules I had been exporting. Once I refreshed the data on PowerBI, I noticed that the data did not change.

I tried this a number of times with different types of signals and capsules and observed the same results. Obviously, from a maintenance and continuity point of view, it is not feasible to start a new OData feed every time there is a change as there is a significant amount of data preparation done on PowerBIs end to get the data to a point where it can be visualized.

Wondering what might be causing this and if there is a way around this? The OData feed was set up to auto update.


The issue was that PowerBI was caching values and even though I was refreshing the data and reconnecting to the OData endpoint, it did not display the new data in the 'edit query' - whether the data did reload and it only displayed the old cached data OR it reloaded but still had the old data and displayed the old data I am not sure of.

Either way, simple fix is to clear your cache and refresh the data. This can be done as follows from PowerBI :

File > Options and settings > Options > Data Load > Data Cache Management Options > Clear Cache 






Thanks to Teddy for the help!

Edited by IB13
Link to comment
Share on other sites

  • Administrators

Are you creating new signals during your updating? If you are creating new signals you will need to create a new export from the export tab.

I tested formula changes on an OData connection to excel and it worked fine for me.  I don’t have a Power BI license to test with.

What version are you on? I can run a test on the same version to check.


Link to comment
Share on other sites

Hi Teddy,

I used the following: 

Seeq Version: R54.1.6

Visualization tool: PowerBI Desktop


OData Feed:

  • Auto Update
  • Automatic Gridding
  • Time range is for the last year


What I did

  • Made a capsule with name X that did a value search on signal Y
  • Exported OData feed to PowerBI
  • Connected and checked the values
  • Change Capsule X to do a value search on a different signal Z
  • Refreshed the data on PowerBI
  • Once the data loaded in, found it was the same.

    I did this for a couple of different signal/capsule combinations.

Edited by IB13
Link to comment
Share on other sites

  • IB13 changed the title to OData Feed does not dynamically update on PowerBI [Fixed]

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...